Перейти к содержимому

Dagot_Prolaps

Dagot_Prolaps

Дата регистрации: 24 дек 2017
Онлайн Активность: Сегодня, 20:32
***--

Рост магических навыков в зависимости от стоимости каста

17 Апрель 2019 - 01:14

Если удастся сделать этот плагин, то решится одна из древнейших проблем Морровинда: не важно сколь сложный спелл вы кастуете - вы всё равно получите стандартный прирост к навыку. В результате манчкины абузили постоянный каст спеллов за 1 маны, а честные игроки не получали никаких преимуществ за пользование тяжёлыми спеллами.

 

Уже существует МВСЕ-мод, вводящий новую механику зависимости роста навыка от стоимости каста. Но он также кардинально меняет систему магии, давая возврат части стоимости заклинаний.

Этот мод использует вот этот страшный скрипт:

 

Спойлер

 

Я обрезал его и привёл в порядок, оставив только часть, ответственную за рост навыков. Нуждается в тесте. Особо обратите внимание на спеллы изменения и комбинированные спеллы. Новый скрипт выверен, но мне кажется, что сама мвсешная функция имеет погрешность для школы изменения.

 

Математически выверенная нелинейная формула прироста опыта:

(Манакост*5) / (Манакост + 80 )

Это +1 опыта за каст спелла на 20 маны,

+2 - за каст на около 50 маны

+3 - за каст на 120 маны

+5 - недостижимый предел

 
Спойлер

Пушки, которые мы заслужили

02 Апрель 2019 - 11:05

9NN3cjlKIUY.jpg
 
Фир скопил за свою жизнь немало двемерских диковинок, аналогов которым нет. Пришло время навестить старикана и обнести его сокровищницу!
 
Найдите 3 уникальных двемерских прототипа убойнейшего оружия.
 
Двемерский скорострельный арбалет с барабанным магазином!
Низкий урон с лихвой компенсируется скоростью стрельбы.
 
Двемерский рейлган с элекромагнитным разгонным механизмом!
Медленный, но если вдарит, то уж наверняка!
Потребляет железные, стальные или серебряные болты, наделяя их электрическим поражающим эффектом.
Серебряные болты получают наилучший электрический эффект.
Заряжается магазинами на 10 болтов.
 
Двемерский взрывострел - вершина гномской оружейной мысли!
Высокая скорость стрельбы вкупе с великолепным огненным эффектом. Разорвите ваших врагов на лоскуты!
Потребляет железные, стальные или серебряные болты, наделяя их огненным поражающим эффектом.
Серебряные болты получают наилучший взрывной эффект.
Заряжается магазинами на 20 болтов.
 
Скачать мод:
 
 
Начинка:
Спойлер
 
 
 

Секта свидетелей святого Экселя

20 Март 2019 - 07:36

1559152_d313.jpg

 

Эксель – это не просто прога. Это – целый язык программирования! А в свете недавнего открытия импорта и экспорта таблиц в КС, теперь это ещё и полноценное продолжение конструктора плагинов. В частности, ребалансов шмоток, существ и даже неписей.

 

 

Как же применить магию Экселя на практике?

 

1) Загрузить в КС свой мод

2) Экспортировать нужные данные (оружие, броня, существа, одежда…)

3) Открыть получившийся текстовый файл и заменить в нём все запятые на точки.

4) Открыть изменённый txt в Экселе. Формат: 1251 – Кириллица (виндовс)

5) Отфильтровать только новые данные из мода.

5.1) Для этого скопировать столбец ID объектов из таблицы данных оригинальной игры рядом со столбцом ID объектов мода.

5.2) Выделить оба столбца. Главная → условное форматирование → правила выделения ячеек → повторяющиеся значения.

5.3) Фильтруем таблицу по цвету и удаляем все помеченные строки. Удаляем скопированный ранее столбец ID. Теперь в вашей таблице только объекты из вашего мода.

6) Редактируем значения.

6.1) Заполняем столбцы S, T, U для оружия и столбцы K, L, M для брони вручную – всё по аналогии с предложенной таблицей из оригинала.

6.2) Если вам нужны новые материалы или модели оружия – переходим на лист Коэф и Коэфбр и создаём новые строки с придуманными вами материалами, прописываем для них коэффициенты.

6.3) На листах Коэф и Коэфбр можно отредактировать стартовые коэффициенты для оригинальных материалов и типов оружия. А для оружия можете даже настроить продвинутое соответствие веса и скорости!

6.4) Копируем нужную формулу в ячейки по всей длине нужного столбца. Готовые ячейки с формулами на страницах оригинальных оружия и брони.

7) Сохраняем готовую таблицу как txt с табуляторами.

8) Меняем в нём запятые на точки.

9) Загружаем в КС свой мод и импортируем нужные данные из этого текстового файла. Готово!

 

 

Весь вышеизложенный алгоритм до 6 пункта я проделал для вас с МФР. В приложенной таблице вы найдёте листы с данными об оружии, броне, одежде и существах как из оригинальной игры, так и только новые объекты из МФР.

Редактируйте по своему усмотрению и создавайте свой самый лучший ребаланс.

Листы с оружием и бронёй оригинала уже полностью ребалансированы – все ячейки заполнены формулами. Можно смотреть на них и делать по аналогии.

 

 

А теперь инструкции по формулам для продвинутых экселистов.

 

Все формулы спроектированы таким образом, чтобы копировать их в нужную ячейку на второй строке таблицы, а затем уже копировать эту ячейку на всю длину столбца. Тогда формула адаптируется ко всему столбцу.

 

ОРУЖИЕ

 

Для всего оружия надо прописать вручную материал и вид в соответствующих столбцах. Также в столбце «маг» желательно прописать коэффициент увеличения цены в зависимости от зачарования (чем круче зачарование – тем выше цифра).

 

Вес:

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 4); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 4));0)

Вес стрел, болтов и металок:

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 4); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 4));1)

 

Цена:

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 2); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 2); СУММ(1; U2));0)

 

Чароемкость:

=ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 3); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 3))

 

Прочность:

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 5); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 5));0)

 

Скорость (для всего кроме призванного и металок со стрелами):

=ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(F2;Коэф!A:A;0); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 13))

Стрелы и болты: всегда 1. Звёзды – 1.5, дротики – 1.0, ножи – 0.7.

Призванные прописать вручную.

Эта формула отличается от остальных, здесь мы узнаём номер столбца, где прописана правильная скорость (7, 8 или 9).

 

Длина:

=ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 10)

 

Руб (мин):

=ОКРУГЛ(ПРОИЗВЕД(M2; ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!$A:A;0); 11));0)

 

Руб (макс):

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 7); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 6));0)

 

Реж (мин):

=ОКРУГЛ(ПРОИЗВЕД(O2; ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 11));0)

 

Реж (макс):

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 8); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 6));0)

 

Кол (мин):

=ОКРУГЛ(ПРОИЗВЕД(Q2; ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 11));0)

 

Кол (макс):

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 9); ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 6));0)

 

Игнор (применять формулу только для немагического оружия):

=ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(T2;Коэф!A:A;0); 13)

 

Тип оружия:

=ИНДЕКС(Коэф!A:Z; ПОИСКПОЗ(S2;Коэф!A:A;0); 12)

 

 

ДОСПЕХИ

 

Для всего сперва надо прописать вручную материал. Для щитов прописать вручную в столбце «щит» 0 для малых щитов и 1 для ростовых.

 

Вес

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(E2;Коэфбр!A:A;0); 4); ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 4));1)

Вес для щитов отдельно:

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(M2;Коэфбр!A:A;0); 4); ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 4));1)

 

Цена

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(E2;Коэфбр!A:A;0); 2); ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 2); СУММ(1; L2));0)

Цены для щитов отдельно:

=ОКРУГЛ(ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(M2;Коэфбр!A:A;0); 2); ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 2); СУММ(1; L2));0)

 

Чароемкость

=ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(E2;Коэфбр!A:A;0); 3); ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 3))

 

Прочность

=ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(E2;Коэфбр!A:A;0); 5); ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 5))

Прочность щитов:

=ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(M2;Коэфбр!A:A;0); 5); СУММ(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 5); ПРОИЗВЕД(ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 6);0,02)))

Это формула улученного коэффициента прочности для щитов: = коэф. прочности брони + АР/50

 

Защита

=ИНДЕКС(Коэфбр!A:Z; ПОИСКПОЗ(K2;Коэфбр!A:A;0); 6)

Для щитов всегда 0.

 

 

 

Далее в этой теме не лишним будет обсуждать предложенные коэффициенты для типов оружия, брони и материалов, цены, урон, защиту, прочность, чароёмкость, вес, а также другие хитрости Экселя. Разбираемся в тонкостях формул, составляем и выкладываем свои продвинутые формулы. Кроме того можно подумать, какие формулы подойдут для быстрого и удобного авторасчёта статов существ – тут всё ещё непаханое поле для экспериментов.


Геймплеистые классы

15 Март 2019 - 02:12

Вшитые в игру классы никуда не годны. Но даже если снабдить оригинальные классы дополнительным скриптовым набором абилок и даже если поменять для них в большинстве случаев идиотский набор главных и важных навыков, это существенно ударит по свободе отыгрыша. Нет уж! Конечно же истинный билдостроитель всегда создаёт свой собственный класс и отыгрывает идеально созданную под себя роль. Но тогда класс героя будет лишён всяческой геймплейной поддержки, да к тому же и никакие скрипты его не подхватят чтобы улучшить геймплей модом. Что же с этим делать? Создавать собственную скриптовую систему классов!

В идеале я хотел бы видеть масштабное древо пассивных умений как в ПоЕ или карту созвездий из Грим Дауна. Но этим мечтам не суждено сбыться, ибо убогий движок Моррки с его напрочь костыльным скриптовым языком в жизни не переварит подобных издевательств. Придётся искать систему попроще. А как насчёт того, что мы уже видели в Масс Эффект Андромеде и Амалуре? А вот такую систему Моррка очень даже потянет! К созданию именно такого мода я и приступил.

 

j9qU3lOyLPs.jpg

 

 

1 – Воин

2 – Маг

3 – Бродяга     

4 – Воитель     

5 – Боевой маг           

6 – Заклинатель

7 – Шпион      

8 – Вор            

9 – Скаут                    

10 – Варлорд              

11 – Паладин  

12 – Спеллсворд        

13 – Шаман                

14 – Архимаг             

15 – Волшебник         

16 – Найтблейд          

17 – Трикстер             

18 – Ассасин              

19 – Плут                    

20 – Блейдмастер       

21 – Варвар                

22 – Герой                  

23 – Искатель             

24 – Странник            

 

Стрелками показано с какого класса на какой можно перейти. Выбирайте свой путь мудро!

Первые 3 – начальные классы-архетипы. Это первая ступень развития Нереварина, получаемая им на 3 уровне Легендарности.

С 4 по 9 идут классы второго тира, они открываются при достижении 6 очков легендарности. Здесь возможно как углубление в выбранном архетипе, так и принятие комбинированного класса.

С 10 по 24 идут высшие классы третьего тира. Они открываются при достижении 10 очков Легендарности и предоставляют очень широкие возможности выбора своего уникального пути.

22, 23 и 24 – небольшая группа универсальных авантюристских классов третьего тира. Для тех, кто любит всё в одном. Разница между ними в небольшом перекосе в сторону воина, мага или бродяги.

 

Очки Легендарности даются за подвиги и легендарные свершения. По одному очку за каждые 10 уровней, +3 за победу над Дагот Уром, +1 за победу над Альмалексией, +1 за победу над Гирцином. Ещё по одному очку за становление главой каждой гильдии, организации или Великого Дома (исключения – Имперский Культ и ВИК). Максимум очков Легендарности = 10.

 

Пассивки архетипа Воина:

+ к максимуму здоровья

сопротивления к стихиям и яду

восстановление здоровья

восстановление стамины

 

Пассивки архетипа Мага:

– к максимуму здоровья

множитель маны

восстановление маны

сопротивление магии

поглощение заклинаний

отражение заклинаний

 

Пассивки архетипа Бродяги:

атака

уклонение

лёгкость

прыжки

сопротивление параличу

 

 

Однотипные классы всё более высоких тиров (например, воин-воитель-варлорд) обладают аналогичным набором пассивных бонусов, но с большей амплитудой. Комбинированные классы соответсвенно обладают пассивками, присущими сразу двум или всем трём архетипам, но в куда меньшем объёме нежели чистый класс.

 

Полный список пассивок каждого класса смотрите в экселевской таблице. Внимательно изучите её, чтобы выбрать лучший класс под свой геймплей.

Классы готовы и вшиты в глобальный геймплейный мод.


Максимум здоровья в зависимости от характеристик

09 Март 2019 - 10:00

Этот плагин устанавливает максимум хп Нереварина в зависимости от базового (то есть не изменённого магией) значения его Выносливости, Силы и Силы Воли. Требует МВСЕ (который входит в состав Фуллрест-репака).

 

Предыдущий плагин на независимый рост хп имел такой скрипт:

 

Спойлер
 
 
Да, сразу видны недостатки - хп просто скакало при изменении статов ГГ магией, кроме того скрипт работал постоянно.
 
В новом же плагине применены МВСЕ-функции для нахождения истинного не изменённого магией значания характеристик героя. Кроме того плагин выполнен в форме стартового скрипта, то есть запускает 1 раз при каждой загрузке игры, а затем завершается, не нагружая более систему.
 
Вот сам скрипт:
 
Begin maxhealth
 
long pcRef
float newhp
float endurance
float strength
float willpower
 
if ( Player->GetHealthGetRatio != 1 )
StopScript "maxhealth"
return
endif
 
if ( Player->GetEffect, sEffectFortifyHealth == 1 )
StopScript "maxhealth"
return
endif
 
if ( Player->GetEffect, sEffectDrainHealth == 1 )
StopScript "maxhealth"
return
endif
 
setx pcRef to xGetRef "player"
setx endurance to pcRef->xGetBaseEnd
setx strength to pcRef->xGetBaseStr
setx willpower to pcRef->xGetBaseWil
set newhp to ( endurance + ( strength * 0.5 ) + ( willpower * 0.5 ) )
Player->SetHealth, newhp
 
StopScript "maxhealth"
 
End
 
Для того чтобы хп перерасчиталось, нужно выполнение следующих условий на момент загрузки сейва:
1) Герой должен быть полностью здоров.
2) На героя не должны влиять эффекты повышения или понижения максимального запаса здоровья (снимите шмотки, зачаренные на постэффект + к максимуму хп, если такие имеются)
 
Формула: Здоровье = Выносливость + Сила/2 + Воля/2
 
То есть на максимуме всех статов у Нереварина будет 200 хп.

Rambler's Top100   Рейтинг@Mail.ru